In Uncategorized

It is our pleasure to announce that Service Pack 4 for flexiVent 5.3 was recently released and is now available for download from the TechNet section of our website. This service pack resolves an intermittent stability issue experienced by some users on more recent EC controller models, recognizable by two Sync connectors on the rear panel. For users of older EC controller models that feature a COM port on the rear panel, this service pack is without effect and does not need to be installed.
Please note that we recommend that you ultimately upgrade you flexiVent system to run on the more recent flexiWare 7 software platform.

Recommended Posts